Image Manipulation with Paint.NET

Common Tasks

Paint.NET v3.5

November 2014
# Table of Contents

Introduction to Paint.NET ........................................................................................................... 3
Installing Paint.NET ..................................................................................................................... 3
Open Paint.NET .......................................................................................................................... 3

Screen Layout ............................................................................................................................. 4
Tools ........................................................................................................................................... 4

General Functions ...................................................................................................................... 5
Open an image file in Paint.NET ................................................................................................. 5
Zoom tool .................................................................................................................................. 5
Pan tool ...................................................................................................................................... 5
Undo and Redo .......................................................................................................................... 5

Printing images from Paint.NET ................................................................................................. 6
Save changes to an opened image .............................................................................................. 6
Save as a new image ................................................................................................................... 6

Working with the image ............................................................................................................. 7
Resize the entire image .............................................................................................................. 7

Selections ................................................................................................................................... 7
Selection modes ......................................................................................................................... 8
Make a selection ......................................................................................................................... 8

Deselect a selection ................................................................................................................... 8
Crop ........................................................................................................................................... 9
Crop to selection ....................................................................................................................... 9

Crop to specific size .................................................................................................................. 9
Resize a selection ....................................................................................................................... 9
Moving a selection ..................................................................................................................... 10
Delete a selection ...................................................................................................................... 10

Extend the canvas size ............................................................................................................. 11

Colors Window (aka. Colour Wheel) ........................................................................................ 12
Popular tools that use colour .................................................................................................... 13
Color Picker ............................................................................................................................... 13

Paint Bucket .............................................................................................................................. 13
Gradient .................................................................................................................................... 13
Paintbrush ................................................................................................................................. 16

Cloning ...................................................................................................................................... 16

Effects Menu .............................................................................................................................. 17
Blurring parts of an image ........................................................................................................... 18
Red eye removal ....................................................................................................................... 19

Adjustments ............................................................................................................................... 20
Layers ......................................................................................................................................... 20

Why are they useful? .................................................................................................................. 25
How to use layers ....................................................................................................................... 25
Add new layer ............................................................................................................................ 26
Move layers ................................................................................................................................ 26
Visible or hidden layers ........................................................................................................... 26

Delete layer ............................................................................................................................... 26

Making a montage using layers and gradients ........................................................................ 26

Bonus material: Other useful tools and options ....................................................................... 28
Recolor ....................................................................................................................................... 28
Text ........................................................................................................................................... 28
Shapes ....................................................................................................................................... 28
Flip/Rotate ................................................................................................................................. 29

Additional Help .......................................................................................................................... 30
Help from Paint.NET .................................................................................................................. 30
Help for images you are creating for the University web pages .............................................. 30

This guide is best viewed electronically to see the images and effects clearly.
Introduction to Paint.NET

Paint.NET is a free image and photo manipulation software for computers that run on Microsoft Windows.

Paint.NET is a program designed to edit bitmaps. Bitmaps are a type of image made up of many small pixels of colour. If you zoom in to part of your image, you will be able to see the detail of each individual pixel. These pixels can be manipulated either individually or as a group by the tools in Paint.NET. There are other more sophisticated bitmap manipulation packages on the market, such as Adobe Photoshop.

This guide is designed to accompany the Paint.NET staff development training.

Installing Paint.NET

Paint.NET can be run on demand from the Application JukeBox (AppJ) – which can be used by staff and students with a Windows PC or laptop. It can be used on and off campus. PC labs already have an AppJ player installed and users just need to logon to the AppJ website and launch Paint.NET to run it when required (active internet connection required at all times). If you do not have Application Jukebox player installed on your computer, you will need to install the player before you can run Paint.NET (or any other AppJ software) on it.

Further information about AppJ, how to download the player, or sign in to launch Paint.NET is available from: [http://appj.lancaster.ac.uk](http://appj.lancaster.ac.uk)

Open Paint.NET

To open the Paint.NET program from your computer:

1. From the **Start** button on the Windows desktop, click in the **Search Programs and Files** box
2. Type in **Paint.NET**
3. Click on **Paint.NET** in the resulting list – see Paint.NET load
Screen Layout

Tools from the toolbox, such as the paint bucket, gradient or eraser can be applied to the whole image or just selected part(s) of the image. The toolbox (tools toolbar) has a variety of tools to enable image manipulation.
General Functions

Open an image file in Paint.NET

1. From the File menu, click **Open**
2. Select the image to open
3. Click **Open**

**Zoom tool**

This is a tool for zooming in and out. To use Zoom, Select the Zoom tool and click the left mouse button to zoom in or click the right mouse button to zoom out.

**Pan tool**

This tool helps move through the image, e.g. scroll across an image if all of it is not visible on the screen at once – it is especially useful to scroll through an image that has a high zoom set.

**Undo and Redo**

Undo and Redo are accessible in a few different locations in Paint.NET – making it really easy to access.

- Undo and Redo options are accessible on the **Edit** menu or on the common actions (standard) toolbar.
- Undo and redo are the same keyboard shortcut keys as Microsoft Office use:
  - CTRL and Z keys for Undo, CTRL and Y keys for Redo.
- The **History** window: a list of actions performed is visible in the History window. To quickly jump back a number of steps, click to the step required.

The number of Undo actions is **not limited**.
Printing images from Paint.NET

1. From the File menu, click Print (or Select the Printer button from the standard toolbar) - depending on the version of Operating System – e.g. Windows 7 or XP, the user may see different screen/options than the picture below.

![Print Picture Options](image)

How do you want to print your pictures?

- Printer:
- Paper size:
- Quality:
- Paper type:

1. Select the printing Options required
2. Click Print

Save changes to an opened image

1. From the File menu, click Save
2. Click OK

Save as a new image

1. From the File menu, click Save As
2. Choose location and file type to be saved as
3. Type a name for the file
4. Click Save
5. Click OK
Working with the image

Resize the entire image

The resize option is located on the Image menu. There are two main methods of resizing – either by percentage or to specify the absolute size of the image. The size can be specified in pixels or length (inches or centimetres) measurements.

1. From the Image menu, click Resize
2. Choose the percentage or type in size required

![Resize dialog box](image)

**Tip:** If you wish the image to resize proportionally, ensure the tick is on Maintain Aspect Ratio
3. Click OK

Selections

You will need to use a selection tool, to select a particular area of the image. Once an area is selected, you can perform a variety of actions, such as, cropping to selection, resizing the selected area, move the selection, delete the selected area or copy and paste the selection.

There are 4 tools available to help select parts of an image - each selection tool has extra options in view controls (options bar). Selection tools include:

- **Rectangle** – make rectangular selections
- **Lasso** – draw a selection shape around the area required
- **Ellipse** – draw a circular selection
- **Magic Wand** – select an area based on similar colours
Some selection tools work better in different situations. For example, to select part of the image which has rectangular sides – the rectangle selection tool may be most accurate. If there is a certain area to select – such as the sky in a photograph – the magic wand may be most suitable (with the selection mode on Add – so the whole sky can be selected in subsections).

**Selection modes**

There are different selection modes available in the view controls (options bar) for each selection tool. By default the selection mode is set to Replace, i.e. the next selection will replace the existing selection.

To add a selection to the existing selection – choose the ‘Add (union)’ selection mode. To remove part of a selection – choose the ‘Subtract’ selection mode.

![Selection Mode Options](image)

The tolerance setting on the magic wand tool is useful. For example, a high tolerance (e.g. 70%) may select a larger related colour area in one click. A lower tolerance (e.g. 25%) can be more accurate if you wish to select a specific colour area. Adjust the tolerance settings depending on the selection requirements, i.e. on how specific you need the selection to be.

**Make a selection**

1. Click the selection tool required
2. Set the selection mode for that tool
3. If using the magic wand, set a suitable tolerance setting
4. Click and drag a selection on the image – see the area become highlighted and the selection area outlined

**Deselect a selection**

1. From the Edit menu, click Deselect
   Or the shortcut is: Using the keyboard, hold the CTRL key and press the D key
Crop

Cropping an image involves selecting the part of the image to be kept – and the rest of the image is discarded.

Crop to selection

1. Using a selection tool, select the part of the image to be kept
2. From the Image menu, click Crop to Selection (or use the crop button on the toolbar)

Crop to specific size

Sometimes you may wish to crop an image to a specific size, e.g. 700 pixels wide by 300 pixels high.

1. Choose the selection tool e.g. rectangle select
2. Change the options in the view controls (top toolbar) from ‘Normal’ to ‘Fixed Size’
3. Change the measurements from ‘inches’ to ‘pixels’
4. Type in the pixel dimensions required in Width e.g. 700 and Height e.g. 300
5. Click and drag mouse on the canvas area to make the selection (if you need to reapply this, just click and drag the mouse until you select the correct area)
6. From the Image menu, click Crop to Selection

Resize a selection

1. Make the selection of the area to be resized
2. Click on the Move Selected Pixels tool
3. See the handles appear around the edge of the selection e.g. in the example to the right, the handles are around the edge of the selected laptop screen
4. Click and drag these handles to resize

Note:
- To keep the selection in proportion: hold down the shift key whilst dragging the selection
- To resize larger: drag the handles outwards
- To make the selection smaller: drag the handles inwards
Moving a selection

Once a selection is made, it can be moved or transformed. There are two move options available in the tools:

- **Move selected pixels**: once a selection is made the ‘Move selected pixels’ tool enables moving, rotating and scaling of the pixels that are selected. In the example the top of the tower has been selected and moved up/to the right.

- **Move selection**: once a selection is made this tool enables moving, rotating and scaling of the selection box – this is useful if the current selection needs modifying. In the example below, the top of the tower was selected, then the selection area was moved up/right. The pixels do not move with the selection.

Delete a selection

When a selection is deleted and there are no more layers of pixels underneath, you will see a grey and white checkerboard pattern denoting transparency. To retain transparency on the image when it is saved; ensure the image is saved as a PNG or GIF file type.

1. Use the selection tools to select the area(s) to be erased
2. Click the DELETE key on the keyboard
3. Save the file as a .gif or .png file type to retain any transparency

The Eraser tool will erase parts of the image selected. This tool can work on separate layers. If there are no more layers underneath the erased pixels, the ‘erased’ parts of the image become transparent.
**Extend the canvas size**

The canvas area can be extended in size - so you can make it the size you require. You may need to do some additional work to the image when you have extended the canvas area e.g. you may decide to do some cloning to make the extended area look the same as the rest of the image or apply a gradient fill (these are covered later in the training session).

1. From the **Image** menu, click **Canvas Size**...
2. Type in the required canvas size e.g. 700 pixels wide by 300 pixels high

![Canvas Size dialog box]

3. Choose the Anchor position required – this is where you would like the existing image positioning in relation to the new sized canvas.
4. Click **OK** – the image is now the required size, however, you may need to do additional activities e.g. cloning and touching up to make it look realistic!
**Colors Window (aka. Colour Wheel)**

The ‘Colors’ window enables the user to select the colour required for the left and right mouse button when using some of the tools, e.g. paint brush, paint bucket.

Choose **Primary** to set the colour for the left mouse button. Choose **Secondary** to set the colour for the right mouse button.

The two squares in the top left side of the Colors window show the current **Primary** and current **Secondary** selected colours. In this example, this means that the black is the primary selected colour (for the left hand mouse button) and White is currently the secondary colour (for the right hand mouse button).

**Note:** Ensure the correct Primary (left mouse button) or Secondary (right mouse button) option is chosen before selecting a colour – to make sure the colour changes for the correct mouse button.

There are a variety of methods of selecting a colour:

- Click a colour from the colour wheel or,
- Select a colour from the palette or,
- Click the ‘More>>’ button to specify certain colours (e.g. type in the RGB, HEX/Web code/HSV value of the colour required). The RGB colour codes for Lancaster University branded colours are:
  - **Red:** R: 181 G: 18 B:27
  - **Grey:** R: 178 G: 183 B:187
Popular tools that use colour

**Color Picker**

Use the colour picker to select a colour from an image to be set as the primary or secondary colours (in the Colors Window)

1. Click **Color Picker**
2. If you require the colour as the primary colour: left mouse click a colour from within the image
3. If you require the colour as the secondary colour: right mouse click a colour from within the image

**Paint Bucket**

The Paint Bucket will colour in ‘blocks’ of area using the current primary colour from the Colors window. Tolerance settings determine how precise the colour fill is. A low tolerance, such as 10, will select colours that are in a very similar colour range; a high tolerance will also select colours that are in a wider colour range.

1. Select required colour
2. Click the **Paint Bucket** tool
3. Choose tolerance options
4. Click areas of the image to be filled in

**Gradient**

**Basic Gradient**

To apply a gradient:

1. Using a selection tool, select the area to apply gradient to (if required). In the example, the sky has been selected.
2. Choose the primary and secondary colours for use in the gradient
3. Click the **Gradient** tool
4. Select the options required on the Gradient view controls (View controls toolbar) – e.g. gradient style
5. Click and drag the gradient line across where the gradient should occur
6. If the gradient isn’t exactly as desired, adjust the gradient ‘nubs’ (these are small circle shapes on the image where you clicked to draw the gradient) or undo the last gradient action and then *reapply* the gradient by dragging the gradient line across the image again
7. If you need to change the gradient colours – change the primary and secondary colours as required – this should update the current gradient
8. If you selected an area in step 1, deselect the selection. The shortcut to deselect is *CTRL* key and *D* key

9. **Save** file if required

**Gradient fade into an image**
Sometimes you need an image to be a specific size and you need a blank space on the left. For example, certain images on the University website have a gradient fill on the left with the main photo on the right. This means the people in the photo are not blocked by the title text.

1. **Open** the photograph required
2. Resize the image to the required size (you may need to extend the canvas area if the photo isn’t wide enough when resized)
3. Choose the **primary colour** required for the gradient e.g. white
4. Set the **secondary colour** to transparent (to do this ensure **Secondary** is selected, click **More>>** and change **Transparency – Alpha** setting to 0)
5. Click the **Gradient** tool
6. Ensure the Gradient is set to **Colour Mode**
7. Drag the gradient as required across the image
8. If the gradient isn’t exactly as desired, adjust the gradient ‘nubs’ (these are small circle shapes on the image where you clicked to draw the gradient) or undo the last action and then **reapply** the gradient by dragging the gradient line across the image again
9. Save changes as required
**Paintbrush**

The brush tool enables ‘freehand’ drawing. The brush options include size of brush and pattern of brushstroke (if required). The paintbrush tool is often used to touch up areas of colour in an image.

1. Select the primary colour required from the Colors window
2. Click Paintbrush tool
3. Select brush options required
4. **Hold down left mouse** button and **drag** mouse to paint

**Cloning**

The Clone stamp enables the user to select an area (size of area is based on the brush width selected) and duplicate it elsewhere on the canvas. It is like painting a replica using brush strokes.

1. Click **Clone Stamp**
2. Choose Cloning options e.g. width of brush
3. Hold the **CTRL** key and click (left mouse button) on the area to be cloned
4. Release **CTRL** key
5. Move the mouse to where the cloning should appear then **click and drag** mouse carefully to paint the clone - see cloning appear

**TIP:** You may need to repeat steps 2-5 a number of times to get an effective clone.

**TIP:** Depending on what you are cloning, you may need a softer edge on the cloned area. (To do this ensure **Primary** is selected in the colour wheel, click **More>>** then change **Transparency – Alpha** setting to about 75)

In the example, an extra pillar is cloned on the right hand side.

**Note:** Cloning is often used in conjunction with other tools to touch up an image.
Effects Menu

There are a range of special effects that can be applied to an image. *Remember the Undo button is available at all times to undo any undesired actions!*

- **Artistic** – provides a range of effects that are meant to look like the image has been drawn artistically e.g. painted or drawn.
- **Blurs** – provide different type of blurring effects
- **Distort** – offers different effects to disfigure the image
- **Noise** – options to add or remove noise from an image
- **Photo** – provides useful effects for photographs – including red eye removal, sharpen and an option to soften portrait pictures
- **Render** – these effects change the image look
- **Stylize** – these effects add some ‘style’ to the image

Here are some examples:

<table>
<thead>
<tr>
<th>Original Image</th>
<th>Ink Sketch</th>
<th>Fragment Blur</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Original Image" /></td>
<td><img src="image2.png" alt="Ink Sketch" /></td>
<td><img src="image3.png" alt="Fragment Blur" /></td>
</tr>
<tr>
<td>Bulge</td>
<td>Add Noise</td>
<td>Sharpen</td>
</tr>
<tr>
<td><img src="image4.png" alt="Bulge" /></td>
<td><img src="image5.png" alt="Add Noise" /></td>
<td><img src="image6.png" alt="Sharpen" /></td>
</tr>
</tbody>
</table>
Blurring parts of an image

If you have used the clone tool to touch up part of an image, you may need to blur parts of it to make it look more realistic. There are a number of blur tools available.

**Note**: When applying blurs you may need to apply them a number of times. It takes practice to decide how strong to set the blurring to look effective. You can always undo an action and repeat it, or add more blurring as required.

Here is the original image that has had the canvas size extended. It needs to be a certain size, so the extra space needs filling in with the grey background colour.

Here is the image after the clone stamp has been used. It is still obvious that the picture has been edited; it does not look realistic as the brush strokes are visible on the left hand side. By using the blur tools to blend the cloning effects, it will make it look more effective.

1. Using a selection tool, select the area of the image to be blurred - do not go right up to the edge of the white table in the image
2. From the **Effects** menu, select **Blurs**
3. Click **Unfocus**...
4. Choose amount of blurring e.g. 10
5. Click **OK**
6. Deselect selection to see if the blurring has improved the image
7. Repeat steps 1-7 as necessary.

**Note**: When close to the edge of another colour, you may prefer to use a different blurring tool – such as the fragment blur.

a. Using a selection tool, select the area of the image to be blurred - do not touch the edge of the other colour
b. From the **Effects** menu, select **Blurs**
c. Click **Fragment**
d. Reduce the distance to a small number e.g. 3, and increase the fragment count as required

![Fragment count](image)

e. Click OK
f. Deselect selection to see if the blurring has improved the image
g. Repeat steps as necessary

---

**Red eye removal**

To help remove red eye on photographs, there is a red eye removal tool.

1. Using a selection tool, select the red eyes
2. From the **Effects** menu, choose the **Photo** option
3. Click **Red Eye Removal**...
4. Adjust the settings as required – see the eyes change accordingly e.g. low tolerance and medium/high saturation.

![Red eye removal](image)

5. Click **OK**
Adjustments

The adjustments menu contains a selection of adjustment options that can be used on an image to enhance it.

Here are brief explanations of each option:

- **Auto-Level**: this option equalises the colours across the whole image, e.g. the dark and light colours appear to be levelled out evenly within the image.

- **Black and White**: makes the image grey scale, e.g. removes the colour.
• **Brightness/Contrast**: options to increase or decrease the brightness and contrast of the image.

• **Curves**: enables the user to adjust the intensity of the colours in the image – the user can make specific parts of the image lighter or darker for adding intensity.
- **Hue/Saturation**: change the hue (colours) of the image, options to increase or decrease saturation (amount of colour in the image) and lightness (which is like changing the brightness of the image).

- **Invert Colors**: upturns the colours of the image. It looks like a photograph negative.
- **Levels**: allows the user to adjust the colour ranges across the image. Drag the black triangular arrows of the Input and Output columns up/down as required – see the image change accordingly.

- **Posterize**: this option enables the user to reduce the amount of colours in the image. It can make the image look more like a drawing/painting than a photograph. Ticking the linked option enables the Red/Greens/Blues of the image to be adjusted by the same amount.
• **Sepia** – this option turns the image Grayscale then adds a tint of brown. The effect is like an old photograph.
Layers

By default there is one layer for the canvas area. Additional layers can be added to ‘stack’ images on top of each other. For example, a section of one photograph – such as a person or animal, can be copied onto a new layer so it is stacked on top of a scenic background to make a different image.

The Layers can be seen in the layers window – in the bottom right of the screen. If this is not visible: from the Window menu, click Layers.

Why are they useful?

Layers are really useful because the content in one layer can be changed without affecting the content any other layers. This is useful when creating a montage of overlapping images as you need to change elements on a layer by layer basis.

Layers can be visible or hidden. Some people add a variety of layers to try out different ideas – then hide the layers they do not wish to use.

The layers window displays which layer is currently selected (the current layer is shaded in blue). In the example below, the current selected layer is Layer 4. It is useful to remember, that the changes made will affect the active layer only – so make sure the correct layer is selected first before editing the image!

In the example below, the original image was a picture of two swans on a lake. In a separate picture was a photograph of a duck.
To add the duck(s) to the swan image:

1. From the duck image, select the duck and copy it
2. On the Swan image, create a new layer (From the Layers menu click Add New Layer) and paste the duck onto the new layer
3. In the example, the duck was too large on the image and did not look realistic, so I clicked on the move selected pixels button and resized the duck by clicking and dragging on the resize handles at the corners of the selection. This makes the duck smaller.
4. To make more ducks—repeat steps 1-3 making slightly different sized ducks to make it more realistic

How to use layers

Add new layer

1. From the Layers menu, click Add New Layers or click the Add New Layer button at the bottom left side of the layers window

Move layers

Moving layers is useful if overlapping layers is an issue. Layers can be re-ordered.

1. Select the layer to be moved and click the blue up arrow or down arrow as needed in the bottom of the Layers window

Visible or hidden layers

1. Deselect the tick at the side of the layer in the layers window to hide the layer
2. To make visible again—reselect the tick

Delete layer

1. Select the layer to be deleted from the layers window
2. Click the red cross at the bottom of the layers window

Making a montage using layers and gradients

1. Open the individual images in Paint.NET
2. Create a new canvas to build the montage on—set the size as required
3. Go to one of the images, then select the pixels required and from the Edit menu, select Copy
4. Go to the blank canvas, from the Edit menu, click Paste into a New Layer
5. Select to Keep Canvas Size if prompted
6. Resize the image to fit – hold the Shift key on the keyboard whilst resizing, to keep the image in proportion. You may need to Zoom out to see the resize handles for the image.

7. Repeat steps 3-6 for all the images. Ensure some overlapping of the images occurs when they are added onto the canvas – this will help with the montage effect.

8. Select a layer to apply a gradient fade to – usually the top layer first

9. Click on the Gradient tool

10. Choose Transparency mode from the View Controls (options bar)

11. Drag a gradient line from where you want the fade to start e.g where the overlap starts to the end of the current image.

12. Deselect the image.

13. Select the next layer down then repeat steps 9 – 11 for each image as required

14. Save changes

15. Choose to flatten the image if prompted

The example below shows three images on separate layers with transparency mode gradients applied to the overlapped areas.
Bonus material: Other useful tools and options

Recolor

The recolor tool will replace the secondary colour in the image with the primary colour. For example, if the secondary colour was red and the primary colour was set to grey, the red in the image would be recolored grey.

Tolerance settings (from the View Controls tool bar) determine the sensitivity of the recoloring. A low tolerance e.g. 0, will replace the colour in the image that exactly matches the secondary colour. A higher tolerance means similar colours will also be recolored.

1. Set the primary colour to be the desired replacement colour
2. Set the secondary colour to be the colour to be replaced
3. Click the Recolor tool
4. Set tolerance as required
5. Click area(s) on canvas area to be recolored

Text

To add some text to the canvas area:

1. Add a new layer
2. Click on the text tool
3. Choose the text formatting options required from the view controls toolbar
4. Click where the text should appear on the canvas area
5. Start typing

Note: use the move pop up button to reposition the text if needed.

Shapes

Rectangular, Elliptical and freeform shapes can be drawn. These shapes have the option to be outline shapes, colour filled shapes or both – filled and outline shapes. The outline width can be altered by changing the shape’s brush width.

Note: The shape fill colour is based on the secondary colour. The shape outline colours is based on the primary colour.

1. Click the shape required from the tools
2. Choose shape options e.g. outline, filled shape, brush width (for outline thickness)
3. Select primary colour for outline of shape (if required)
4. Select secondary colour for shape fill
5. Draw shape – click and drag mouse button on the canvas area

**Flip/Rotate**

To *rotate* or *flip* the entire image:

1. From the **Image** menu click the option required, for example:

   ![Original](image1.png)  ![Flip Horizontal](image2.png)
   
   ![Flip Vertical](image3.png)  ![Rotated 90 Clockwise](image4.png)
Additional Help

Help from Paint.NET

Access Paint.NET help from Help menu in Paint.NET or press F1 function key as a shortcut. The Paint.NET help provides good explanations of all aspects of Paint.NET.

Help for images you are creating for the University web pages

Please email webmaster@lancaster.ac.uk with your enquiry.